UK Kiosk / Mobile payments - Microsoft Azure outage

Incident Report for Tangerpay

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 10:00 AEST

Update

Microsoft Azure latest update shows them expecting to have all services fully restored globally by 10am AEST. We will continue to monitor and provide updates.

Kiosk and Mobile payments are operational at most locations, if kiosk payments are failing at your site, please have the customer pay using Mobile Pay.
Posted Oct 30, 2025 - 09:16 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 08:25 AEST

Investigating

We have received reports of transaction timeouts in the the UK on Kiosk and Mobile payments. Some (but not all) kiosk payments in Australia are also affected.

The root cause for this outage has been identified to be a disruption on a critical cloud server provided by Microsoft outage which has affected thousands of businesses gloabally including Microsoft itself.

Internet services are restoring globally as Microsoft restore services. Azure cloud computing platform, which underpins large parts of the internet, had reported a "degradation of some services" due to a "DNS issues". For the most up to date information you can refer to Microsoft's status page: https://azure.status.microsoft/en-us/status

As it is a DNS issue, some transaction may fail until the Microsoft DNS change propagates out to all servers globally. We are seeing servers recover, but depending where you are located it may take a DNS server located locally to you longer to recover.

We will continue to monitor the situation.
Posted Oct 30, 2025 - 04:00 AEST
This incident affected: Kiosk Payments (Series 1 Kiosk, Series 2 & 3 Kiosk, Kiosk Max & Mega Series 3) and Mobile QR Payments.